Sorry this site needed adobe flash 10+ support.
Download Flash here.